Jan 5th, 2023

For all customers with the following zAgileConnect Salesforce package versions:

v1.9 to v1.11.11

v1.13.x

v1.14 - 1.14.5

Summary of Changes that will impact zAgileConnect functionality

Salesforce will be retiring API versions 21.0 through 30.0 in the Summer '23 Release. For more details, please refer to Salesforce Platform API Versions 21.0 through 30.0 Retirement.  This update will affect the functionality of zAgileConnect package versions listed above.  

The following note has been provided by Salesforce.

Prior to the Summer '23 release, customers and partners must modify or upgrade their applications to function with the most current API versions. Moving to newer versions of our APIs will offer advanced capabilities with improved security and performance

Recommended Actions

You have two options:

1. Upgrade zAgileConnect to v1.14.6 (Recommended for all customers with 1.9.x, 1.11.x, 1.13.x and 1.14.x versions)

Upgrade zAgileConnect to v1.14.6 version, refer to the upgrade upgrade steps depending on the Jira version:

2. Or, Upgrade zAgileConnect to v1.11.12 (for customers with 1.11.x, 1.9, or earlier versions of zAgileConnect only)

Upgrade zAgileConnect to v1.11.12 version if you are on older versions of zAgileConnect and do not want to upgrade to most recent major release. Refer to the  zAgileConnect v1.11.12 Release Notes  to find the link to install the Salesforce Package and for Jira Data Center and Jira Server refer to the compatibility matrix for Jira Server and Jira Data Center to find a v.1.11.x compatible Jira Add-on.

Jira Data Center and Jira Server Warning

For Jira Server and Jira Data Center customers, please make sure to upgrade the zAgileConnect package and the corresponding zAgileConnect Jira add-on that is compatible with the package.

To check the version of the zAgileConnect Jira Add-on that is compatible with the Salesforce package, please refer to the compatibility matrix above.