'There is no access to some fields for Case' error message on Salesforce properties panel
Problem
When accessing the Salesforce properties panel of an Issue in Jira with one or more related Cases, the following message is displayed:
Cause
Some of the fields mapped in 'Select Case-related properties' (via zAgileConnect package configuration in Salesforce) are not accessible to the Salesforce Integration user via field-level security configuration in Salesforce Setup.
Diagnosis
- Go to Salesforce Setup → App Setup → Installed Packages → zAgileConnect → Configure ,
- Enter the configuration step Select Case-related properties and source for Attachments to send to JIRA,
- On Case Properties tab, look for the field(s) that has a warning icon next to it (Warning icon indicates that this field is not accessible from JIRA to the Salesforce Integration user).
- Identify the Salesforce Integration user by going to Salesforce Setup → App Setup → Installed Packages → zAgileConnect → Configure → Sign In to JIRA and look for the Salesforce Integration User in zAgileConnect Add-on Connection section:
Resolution
Once the non accessible field(s) are identified you can change their field-level security to make the field 'visible' for the Profile of the Salesforce Integration User.
You can check the field-level security in Salesforce Setup→ App Setup → Customize → Cases → Fields and clicking on the field label.